July 22, 2024, 06:14:06 pm
Welcome, Guest. Please login or register
News:

Arturia Forums



Author Topic: Faders controlling pitchbend in DAW mode (SOLVED)  (Read 3100 times)

decredis

  • Apprentice
  • *
  • Posts: 13
  • Karma: 0
Faders controlling pitchbend in DAW mode (SOLVED)
« on: October 11, 2019, 05:36:34 pm »
Hi, I've just got a KeyLab 88 mkII, and I found that in DAW mode the faders all control pitchbend (and possibly sending a note too) by default... is this normal, and can it be changed?

Here's a few lines from my midi monitoring software MIDI-OX when moving a fader:
33362  3  --    144   104     0    1  G# 7 Note Off 
33370  3  --    144   104   127    1  G# 7 Note On   
33370  3  --    224    31    22    1  ---  Pitch Bend

(And if I use MIDI Learn to assign another parameter to a fader, it still also controls the pitch bend!)
« Last Edit: October 14, 2019, 02:53:15 pm by decredis »

LBH

  • Hero Member
  • *****
  • Posts: 4.920
  • Karma: 261
Re: Faders controlling pitchbend in DAW mode
« Reply #1 on: October 11, 2019, 11:49:17 pm »
Hi and welcome to Arturia fourms.

I don't have a Arturia controller. But this sounds strange.
Which DAW do you use?
Have you set your controller up as a Mackie? MCU or HUI protocol?
Do you use the latest firmware for the controller?
Which computer OS do you use?

decredis

  • Apprentice
  • *
  • Posts: 13
  • Karma: 0
Re: Faders controlling pitchbend in DAW mode
« Reply #2 on: October 12, 2019, 11:53:24 am »
Thanks for reply... yes Iíve upgraded the firmware. I use Cubase, but I donít think the issue is DAW specific, because this is happening when I just connect it to the computer and open the midi monitoring software MIDI-OX, which simply displays whatever midi data the keyboard outputs.

I donít understand your question about setting up as Mackie or the protocols, can you point me towards a guide on this aspect?

Iím on Windows 10.

Thanks

decredis

  • Apprentice
  • *
  • Posts: 13
  • Karma: 0
Re: Faders controlling pitchbend in DAW mode
« Reply #3 on: October 12, 2019, 12:22:45 pm »
Ok, Iíve been into the midi control centre device settings tab: when I have the DAW map set to Cubase or Default MCU, the faders output pitch bend and a high G#. When I select HUI, they donít work at all: they donít control anything and canít be used to Midi Learn to.

LBH

  • Hero Member
  • *****
  • Posts: 4.920
  • Karma: 261
Re: Faders controlling pitchbend in DAW mode
« Reply #4 on: October 12, 2019, 01:28:15 pm »
The important thing is, if it works in Cubase. I believe it should.
You can read in your keyboards manual, what the faders and other controls should control in the DAW. Is the right controls being controlled?

Have you set up your controller like shown in the Cubase part in this FAQ: https://www.arturia.com/faq/keylabmkii/keylab-mkii-tips-tricks
Note the following note in the guide: "Note: the ports are called MIDIIN2 and MIDIOUT2 on Windows"

« Last Edit: October 12, 2019, 02:07:11 pm by LBH »

decredis

  • Apprentice
  • *
  • Posts: 13
  • Karma: 0
Re: Faders controlling pitchbend in DAW mode
« Reply #5 on: October 12, 2019, 03:19:23 pm »
Thanks for the tip, I didn't know about setting it up as a Mackie. Having done that, the faders do control the Cubase faders they're meant to control, but they still also output a high G# note and a pitchbend signal as well as controlling the faders.

I have since heard back from the shop I bought the keyboard from, and they think it's a fault, and have offered to swap it with another unit once they have one in stock.

LBH

  • Hero Member
  • *****
  • Posts: 4.920
  • Karma: 261
Re: Faders controlling pitchbend in DAW mode
« Reply #6 on: October 12, 2019, 03:46:41 pm »
You are welcome.

Good it works.

I'm not sure there is a fault. In DAW mode the faders are using a MCU or HUI protocol. I'm not sure that Midi OX read this correct. Do you know that?
But if you feel better to get a new unit, then do so.

decredis

  • Apprentice
  • *
  • Posts: 13
  • Karma: 0
Re: Faders controlling pitchbend in DAW mode
« Reply #7 on: October 12, 2019, 04:27:25 pm »
The faders controlling pitch bend and emitting high pitched notes is surely not whatís meant to happen, as it makes the faders unusable in DAW mode, but I guess itís possible thereís a solution without replacing the device. Itís not just midi-ox: midi-ox is documenting what I can also hear when I move the faders in Cubase:  the pitch is bending and itís playing those high pitched G# notes (as well as the Cubase fader being properly controlled, now Iíve set it up as Mackie).
« Last Edit: October 12, 2019, 04:32:26 pm by decredis »

decredis

  • Apprentice
  • *
  • Posts: 13
  • Karma: 0
Re: Faders controlling pitchbend in DAW mode (SOLVED)
« Reply #8 on: October 14, 2019, 02:55:12 pm »
Arturia support have been very rapid and helpful. It turns out I just hadnít set things up right in Cubase... as you suggested, @LBH, the pitchbend and note data were misinterpretations of HUI protocol data. The solution was to ensure that my Cubase tracks were not receiving input from ďall midi inputsĒ but just the Keylab. Cheers!

 

Carbonate design by Bloc
SMF 2.0.17 | SMF © 2019, Simple Machines