May 26, 2024, 04:54:26 am
Welcome, Guest. Please login or register
News:

Arturia Forums



Author Topic: How to disable transpose of sequence from external midi controller?  (Read 4572 times)

whyistherenophonesupport

  • Apprentice
  • *
  • Posts: 11
  • Karma: 0
So I have a sequence recorded/playing back to a synthesizer. Synth is hooked up midi in/out to BSP. When sequence is playing, if I go to play another part on the keyboard (some chords above the sequenced bass line, for example), it transposes the sequence. This is very unintuitive, and doesn't make sense in a live setting. How do I disable the transpose? In MCC Device Settings I have the transpose channel set to a different channel that what I'm using, and I also have it set to USB.

edit: after further research, it appears there's no way to do this. Putting this thing back up for sale, it's so clunky to use in a live scenario, and I can't wait two days for support every time I have a question. What a joke.
« Last Edit: February 12, 2019, 06:40:53 pm by whyistherenophonesupport »

megamarkd

  • Hero Member
  • *****
  • Posts: 835
  • Karma: 38
  • Dead By Dawn
Re: How to disable transpose of sequence from external midi controller?
« Reply #1 on: February 13, 2019, 12:37:57 am »
What synth are yo using?
Currently running https://www.modulargrid.net/e/racks/view/1311723 / www.modulargrid.net, sequencing with KSP and recording with a Zoom (no DAW involved, for better or worse ;) )

whyistherenophonesupport

  • Apprentice
  • *
  • Posts: 11
  • Karma: 0
Re: How to disable transpose of sequence from external midi controller?
« Reply #2 on: February 13, 2019, 07:00:38 pm »
I've tried a few. It wouldn't actually matter, would it? Currently using a CZ1000. Very straightforward midi in/out to the BSP.

Submitted help request to Arturia the day before yesterday, just got email this morning that they received it and it could be up to 48 hours for a response, sometimes more. This company is awful; can't even get a really basic question answered. Lesson learned.

megamarkd

  • Hero Member
  • *****
  • Posts: 835
  • Karma: 38
  • Dead By Dawn
Re: How to disable transpose of sequence from external midi controller?
« Reply #3 on: February 14, 2019, 01:22:25 am »
With the CZ1000, have you tried setting the same patch to two channels so that you can have the BSP address one channel and your soloing on another that won't interfere with the BSP?  All the multi-timbrel synths I know of can be set to work in that manner with a little playing around with layers.
You should be a little patient with the support team maybe.  They aren't a huge company and their support team is tiny when you consider they are attending to software, controller, synths, sequencers and interfaces they have on the market currently.

edit:
I just double checked the options in MCC.  Have you tried setting the transpose input port to USB (considering you are using the "physical" MIDI input port) and setting the transpose channel to a completely different channel to either of the melody sequencers?
« Last Edit: February 14, 2019, 05:03:43 am by megamarkd »
Currently running https://www.modulargrid.net/e/racks/view/1311723 / www.modulargrid.net, sequencing with KSP and recording with a Zoom (no DAW involved, for better or worse ;) )

whyistherenophonesupport

  • Apprentice
  • *
  • Posts: 11
  • Karma: 0
Re: How to disable transpose of sequence from external midi controller?
« Reply #4 on: February 14, 2019, 08:48:26 pm »
I can fiddle with the multitimbral settings, but that's a poor workaround that would result in me using two channels on the synth for the same exact tone, when really I should be able to play notes without transposing the sequence. This is a basic function that's existed on midi sequencers for decades.

Regarding the MCC transpose options, I've tried every combination of USB/MIDI/different channels, etc. Setting the transpose to USB makes no difference and there's only a vague description of what this functionality does in the manual, so I have no idea what that is supposed to do.

Also, don't defend a company that can't adequately support the products it sells. These are not exactly cheap devices, and this is not a boutique manufacturer handbuilding modules.

megamarkd

  • Hero Member
  • *****
  • Posts: 835
  • Karma: 38
  • Dead By Dawn
Re: How to disable transpose of sequence from external midi controller?
« Reply #5 on: February 18, 2019, 05:18:24 am »
I've taken a good look at the various ways to transpose the BSP.  I don't know the reasoning for transpose being always the behaviour when it receives notes on the SEQ MIDI receive channel but it would seem it's the intended behaviour.  I've worked out (or rather reminded myself) that the Transpose Input Port only affects the Transpose Channel and intended beaviour.  Using a Keystep or a Novation controller, it is easy to change MIDI channel without having to menu dive making for as quick a change as it is to go from record to play on the BSP.  I am not familiar with the CZ1000 so have no idea if does require menu diving to change it's current patch channel or if it's as simple as a single button press (as is with my Novations controllers).
It's a shame if you feel that the sequencer is not worth keeping if you can't work this out, as it really is a great sequencer (I use it more than I do my Pyramid).
Currently running https://www.modulargrid.net/e/racks/view/1311723 / www.modulargrid.net, sequencing with KSP and recording with a Zoom (no DAW involved, for better or worse ;) )

whyistherenophonesupport

  • Apprentice
  • *
  • Posts: 11
  • Karma: 0
Re: How to disable transpose of sequence from external midi controller?
« Reply #6 on: February 18, 2019, 07:32:39 pm »
It would be less frustrating if there were a support team to talk to about this. As is, I submitted a request last Tuesday, and just received a response this morning (Monday). However, the response just told me to look at the transpose input port in MCC, which contradicts what I (and yourself) found to only affect transpose channel. Currently awaiting another response that is more helpful, or at least a confirmation that the transpose input port only affects the transpose channel and not my scenario.

I do appreciate you looking into it @megamarkd.

Bigtoop

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
I'm having the exact same issue apart from my synth being DSI Prophet '08. Midi out going from Prophet to BSP, midi in going from BSP to Prophet. MCC's Transposition latch on/off makes a difference, but the channel and port options won't make any difference. My purpose would be to record sequences straight from the Prophet's keyboard to BSP. Everything else works as expected, but this problem renders the whole midi in controlling unusable.
« Last Edit: May 07, 2019, 10:33:22 pm by Bigtoop »

angstrom

  • Apprentice
  • Apprentice
  • *
  • Posts: 11
  • Karma: 0
I'm experiencing the same problem. It seems like a bug to me.

no matter what channel I set in the MCC for transpose, or the ports - it's transposing the sequencers when I don't want to.

EG: MIDI keyboard playing via USB on Channel 1
Sequencer 1  is set to accept MIDI channel 1. 
Transpose  in MCC is set to "MIDI port only" and to receive on  Channel 13 (which is unused)

I can record notes just fine, etc. into Seq 1, but if I Seq 1 is playing and I touch my master midi controler, and play on Channel 1,2,3,4,5,6,7,8 ...   it will transpose Sequencer 1 and Sequencer 2.

To be clear: Pattern Transpose is recieving on all ports and all channels and no combination of MCC setting is deactivating this

danny-gets-a-green-tea

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Re: How to disable transpose of sequence from external midi controller?
« Reply #9 on: June 08, 2020, 06:39:31 am »
Same behavior as described above here using a Moog Grandmother. Does anyone has any news about this?

savupiippulissu

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Re: How to disable transpose of sequence from external midi controller?
« Reply #10 on: June 30, 2020, 01:54:29 am »
Hello.

I have the same issue as you guys. I don't think it has to do with the external MIDI controller/Master Keyboard used for inputting notes onto the Beatstep Pro. I have tried multiple keyboards and the behaviour is always the same. One of those keyboards happens to be the Arturia Keystep.

I have made sure that said keyboards are not outputting on the 'Transposition' MIDI channel set in Midi Control Center. This test was done with MIDI OX software. In addition to this problem I spotted another one. Whilst Keystep Pro an empty sequence, no MIDI is passed through to the connected synth itself.

For example, my chain is as follows:
Keystep MIDI ch. 12 -> Beatstep Pro (which has Sequencer 2 receiving on channel 12, this is set to output on channel 2) -> Behringer Neutron (set to receive on MIDI channel 2).
START empty sequence on Beatstep Pro and play notes on Keystep -> No MIDI fed to Neutron.
START AND RECORD -> Played notes ARE fed to Neutron AND are also recorded into Beatstep Pro sequence 2. This is as it should be.
DEACTIVATE RECORD and let sequence play on Beatstep Pro AND play notes on Keystrep -> Recorded Sequence is being Transposed no matter what settings are selected in Midi Control Center.

I find it hard to believe this is the way Arturia designed this product to work.

I have sent a help request just 12 hours ago and will let you guys know what they recoomend as a solution.

-Roope

CountDooku

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Re: How to disable transpose of sequence from external midi controller?
« Reply #11 on: April 22, 2021, 02:40:12 am »
Did anyone find a solution to this problem? I am having the same issue. None of the transposition settings in Midi Control Center does anything.

DingLuKai

  • Apprentice
  • *
  • Posts: 10
  • Karma: 0
Re: How to disable transpose of sequence from external midi controller?
« Reply #12 on: March 20, 2022, 01:21:33 pm »
Has this issue ever been resolved?

Kykus

  • Apprentice
  • *
  • Posts: 4
  • Karma: 0
Re: How to disable transpose of sequence from external midi controller?
« Reply #13 on: July 20, 2022, 03:37:26 pm »
hi, I'm having the same problem. My keystep is plugged to midi in on the Beatstep Pro and whenever I play a note on it, it transposes the entire sequence. I still havenít found a solution, has there been one?

 

Carbonate design by Bloc
SMF 2.0.17 | SMF © 2019, Simple Machines