April 16, 2024, 03:43:35 pm
Welcome, Guest. Please login or register
News:

Arturia Forums



Author Topic: RGB LED strip above my keyboard on the Keystep37 have turned themselves off?  (Read 1570 times)

Synthcrazy

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Hi.

The RGB LED strip above my keyboard on the Keystep37 seem to have turned themselves off, or are faulty and do not respond to keyboard inputs etc. How do you turn them back on again please? I cannot see any option in the midi control centre, to turn them on nor on the keyboard. Is this a fault? I have only used it a few hours, maybe I have missed something in the manual.  ??? Please advise.

Thank you in advance for any replies.

jlx

  • Guest
Same for me. I just used it for 2h or so and all LEDs have stopped working, including the chord button led. Even after a factory reset it won't work anymore.

Synthcrazy

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
I have managed to send mine back to Thomann, under warranty, as they couldn't diagnose the fault.  I advise sending it back to your retailer or whoever the guarantee is with.  I am sure we are not the only ones to have this problem.  It seemed to occur after an update and resetting it didn't solve the problem.

Phil B

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Beware MCC! I had this problem too. My new KeyStep37 arrived last week and worked fine until yesterday. So disappointed. Then I remembered Midi Control Centre (current version 1.14.1.2) had asked to update my firmware and I had accepted. So I checked the firmware in MCC and it was now showing KeyStep 37 firmware as 1.0.4. I checked https://www.arturia.com/products/hybrid-synths/keystep-37/resources and found the latest should be 1.1.6.579.

So its a bug in MCC. The fix is to download the correct firmware and reinstall it using MCC. Come on Artura! KeyStep 37 is a great product but that is a sloppy error causing people a lot of grief and inconvenience.

davew

  • Apprentice
  • *
  • Posts: 20
  • Karma: 3
The fix is to download the correct firmware and reinstall it using MCC.
Many thanks for this. The chord button on my Keystep 37 was no longer lighting up, and this fixed it. I hope the MCC bug gets fixed soon.

 

Carbonate design by Bloc
SMF 2.0.17 | SMF © 2019, Simple Machines