June 18, 2024, 11:06:17 pm
Welcome, Guest. Please login or register
News:

Arturia Forums



Author Topic: [SOLVED]BeatStep Pro Not Sending CC Messages in Control Mode  (Read 10227 times)

tallgeese

  • Apprentice
  • Apprentice
  • *
  • Posts: 5
  • Karma: 0
[SOLVED]BeatStep Pro Not Sending CC Messages in Control Mode
« on: August 09, 2015, 06:45:10 am »
I created a custom control map using undefined CC#20 - CC#31 using USB&MIDI for knobs 1-6 and 9-14 respectively. I attempted to perform midi learn on Addictive Drums, Rapture Pro, and Z3ta, but discovered BeatStep Pro Fw. v1.1.1.6 isn't sending CC messages.
« Last Edit: July 17, 2017, 03:12:56 pm by I grec »

turbo_kev

  • Sr. Member
  • ****
  • Posts: 315
  • Karma: -97
Re: BeatStep Pro Not Sending CC Messages in Control Mode
« Reply #1 on: August 09, 2015, 02:54:29 pm »
Hi
I am having almost the same problem

But for me its sending cc's in control mode  in stand alone mode with a arturia mini v2

but inside my daw BitWig studio  it wont allow midi learn to the vst

but it will allow cc's to midi learn  the daw controls

my old beatstep 1    works perfectly in everything

so something strange is going on with control mode in the BSP

cheers
kev
BWS 3.0.0,Spark LE, V Collection 6.2, BS1 & BS PRO, Keystep & Keystep pro  keylab 25, Axiom pro 49,Behringer UMC1820,Launch pad pro,ProFx8 v2,Icon m+ & D2,KRK 10/3,win 10 pro,i7 5820k 4ghz ,16G ddr 4 ,1TB NVMe.M2, msi x99a sli + , NV GF Gt 710, Matrix Brute  Roland TR8S

turbo_kev

  • Sr. Member
  • ****
  • Posts: 315
  • Karma: -97
Re: BeatStep Pro Not Sending CC Messages in Control Mode
« Reply #2 on: August 11, 2015, 03:50:28 pm »
Come on somebody must have the answer ?

cheers
kev
BWS 3.0.0,Spark LE, V Collection 6.2, BS1 & BS PRO, Keystep & Keystep pro  keylab 25, Axiom pro 49,Behringer UMC1820,Launch pad pro,ProFx8 v2,Icon m+ & D2,KRK 10/3,win 10 pro,i7 5820k 4ghz ,16G ddr 4 ,1TB NVMe.M2, msi x99a sli + , NV GF Gt 710, Matrix Brute  Roland TR8S

tallgeese

  • Apprentice
  • Apprentice
  • *
  • Posts: 5
  • Karma: 0
Re: BeatStep Pro Not Sending CC Messages in Control Mode
« Reply #3 on: August 12, 2015, 03:28:47 am »
The Arturia MCC is a little obtuse (IMO) and buggy.

Setting MIDI CC on the BS Pro does work. I'll post the steps I used that work ASAP.

There is a bug in the MCC GUI. After the BS Pro is synced with the MCC, turning a knob may highlight the subsequent numbered step buttons; just a visual bug, not an operational problem.   

Terrym

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1.542
  • Karma: 40
    • soundcloud.com/logicaldream
Re: BeatStep Pro Not Sending CC Messages in Control Mode
« Reply #4 on: August 12, 2015, 03:56:31 pm »
Hi all . In the mcc control panel make sure you set each control midi ports to midi &usb and midi channel to user  otherwise the controls will not work on your daw.
theres a new mcc and FW coming


regards

terrym
TerryM
ARTURIA Tester for Minifreak,All software Polybrute,Keystep pro,Audiofuse range, Microfreak,Kl49mkII,DrumBrute,Spark,Analog lab3,KLE,kl88,matrix12,Semv,Beatstep,Minibrute 2,Pigments
ASC,Vcol6, Beatstep pro, VCOL8, Synclavier v.Minibrute2s

turbo_kev

  • Sr. Member
  • ****
  • Posts: 315
  • Karma: -97
Re: BeatStep Pro Not Sending CC Messages in Control Mode
« Reply #5 on: August 12, 2015, 05:23:05 pm »
Hi Mr T

I have set this in the MCC     if it was not correct
then it wouldn't work  in stand alone   but it does

and in Bitwig  if I midi learn any of the controls IE faders on the mixer
as soon as I turn a knob on the BSP it works

its just when I use Miniv 2 as a vst and selct midi learn and turn a knob on the BSP it does NOT work
but again if I select any other feature of BitWig and turn a knob it DOES work

its as if there is something blocking the CC's from getting through to the vst

so I thought may be this is a Bitwig problem

but it cant be Bitwig   because if I choose my old BS 1 as the input everything works

anything else you think I could be doing wrong ??

cheers
the pain in Spain
Kev
BWS 3.0.0,Spark LE, V Collection 6.2, BS1 & BS PRO, Keystep & Keystep pro  keylab 25, Axiom pro 49,Behringer UMC1820,Launch pad pro,ProFx8 v2,Icon m+ & D2,KRK 10/3,win 10 pro,i7 5820k 4ghz ,16G ddr 4 ,1TB NVMe.M2, msi x99a sli + , NV GF Gt 710, Matrix Brute  Roland TR8S

turbo_kev

  • Sr. Member
  • ****
  • Posts: 315
  • Karma: -97
Re: BeatStep Pro Not Sending CC Messages in Control Mode
« Reply #6 on: August 12, 2015, 05:33:39 pm »
Hi Mr T

if you want to see exactly what I mean

you can take over my Pc with teamviewer  and see for yourself

let me know if your willing to take a look

cheers
kev
BWS 3.0.0,Spark LE, V Collection 6.2, BS1 & BS PRO, Keystep & Keystep pro  keylab 25, Axiom pro 49,Behringer UMC1820,Launch pad pro,ProFx8 v2,Icon m+ & D2,KRK 10/3,win 10 pro,i7 5820k 4ghz ,16G ddr 4 ,1TB NVMe.M2, msi x99a sli + , NV GF Gt 710, Matrix Brute  Roland TR8S

Terrym

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1.542
  • Karma: 40
    • soundcloud.com/logicaldream
Re: BeatStep Pro Not Sending CC Messages in Control Mode
« Reply #7 on: August 12, 2015, 05:58:37 pm »
Im afraid my time is short so i don't have time to sync up but i will look at this tonight .


regards

Terrym
TerryM
ARTURIA Tester for Minifreak,All software Polybrute,Keystep pro,Audiofuse range, Microfreak,Kl49mkII,DrumBrute,Spark,Analog lab3,KLE,kl88,matrix12,Semv,Beatstep,Minibrute 2,Pigments
ASC,Vcol6, Beatstep pro, VCOL8, Synclavier v.Minibrute2s

Terrym

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1.542
  • Karma: 40
    • soundcloud.com/logicaldream
Re: BeatStep Pro Not Sending CC Messages in Control Mode
« Reply #8 on: August 12, 2015, 06:03:58 pm »
Also open the mcc  while connected in bitwig open midi console at the top press sync and in control mode turn a few knobs are they showing up in the midi console?
TerryM
ARTURIA Tester for Minifreak,All software Polybrute,Keystep pro,Audiofuse range, Microfreak,Kl49mkII,DrumBrute,Spark,Analog lab3,KLE,kl88,matrix12,Semv,Beatstep,Minibrute 2,Pigments
ASC,Vcol6, Beatstep pro, VCOL8, Synclavier v.Minibrute2s

turbo_kev

  • Sr. Member
  • ****
  • Posts: 315
  • Karma: -97
Re: BeatStep Pro Not Sending CC Messages in Control Mode
« Reply #9 on: August 12, 2015, 08:54:53 pm »
Hi

you cant open the MCC while Bitwig is running  ?
you cant sync the BSP

message is   the device is connected but not synchronized

all I get in the midi console is  OUT F0 7E 7F 06 01 F7   SYSEX
repeated over and over

but without Bitwig running when I turn some knobs I get  decay time, chorus send,brightness  etc etc

One other strange thing i'v just noticed
the BSP cc's  work on the Bitwig stuff in midi learn but not the vst
but the old BS 1 works in control mode on the vst   but NOT on the Bitwig stuff

cheers
kev
« Last Edit: August 12, 2015, 09:20:15 pm by turbo_kev »
BWS 3.0.0,Spark LE, V Collection 6.2, BS1 & BS PRO, Keystep & Keystep pro  keylab 25, Axiom pro 49,Behringer UMC1820,Launch pad pro,ProFx8 v2,Icon m+ & D2,KRK 10/3,win 10 pro,i7 5820k 4ghz ,16G ddr 4 ,1TB NVMe.M2, msi x99a sli + , NV GF Gt 710, Matrix Brute  Roland TR8S

tallgeese

  • Apprentice
  • Apprentice
  • *
  • Posts: 5
  • Karma: 0
Re: BeatStep Pro Not Sending CC Messages in Control Mode
« Reply #10 on: August 13, 2015, 05:03:58 am »
Did you put the BS Pro in Control Mode and create a new MIDI CC mapping?

turbo_kev

  • Sr. Member
  • ****
  • Posts: 315
  • Karma: -97
Re: BeatStep Pro Not Sending CC Messages in Control Mode
« Reply #11 on: August 13, 2015, 03:22:31 pm »
HI all

After getting a reply from the Boyz at BitWig

this problem for me is now sorted

it turns out it was the script that I was using wasn't routing
the cc's properly

so I will have to put up a request for a better script

unless Arturi is going to supply one

cheers
kev
BWS 3.0.0,Spark LE, V Collection 6.2, BS1 & BS PRO, Keystep & Keystep pro  keylab 25, Axiom pro 49,Behringer UMC1820,Launch pad pro,ProFx8 v2,Icon m+ & D2,KRK 10/3,win 10 pro,i7 5820k 4ghz ,16G ddr 4 ,1TB NVMe.M2, msi x99a sli + , NV GF Gt 710, Matrix Brute  Roland TR8S

bufobufo

  • Apprentice
  • Apprentice
  • *
  • Posts: 7
  • Karma: 4
Re: BeatStep Pro Not Sending CC Messages in Control Mode
« Reply #12 on: August 21, 2015, 07:09:13 am »
Hey turbo_kev,

Can you tell in more detail where my controller script "wasn't routing the cc's properly"?

So I can fix it in the script.

Thank you! 

turbo_kev

  • Sr. Member
  • ****
  • Posts: 315
  • Karma: -97
Re: BeatStep Pro Not Sending CC Messages in Control Mode
« Reply #13 on: August 21, 2015, 02:27:27 pm »
Hey turbo_kev,

Can you tell in more detail where my controller script "wasn't routing the cc's properly"?

So I can fix it in the script.

Thank you!


HI I will try my best so that you can understand the problem I am having

1.  To make it simple I will use 1 vst Arturia miniV2
2.  use my BSP to control the track with the miniV 2
3.  select from the drop down menu your script channel 1
4.  start bitwig and the sequence plays OK
5.  now while the sequence is playing  put the BSP in CONTROL MODE
6.  put the miniv2 in to midi learn mode
7.  click a knob on the miniv2
8.  turn a knob on the BSP and NOTHING happens
9.  right click on any BitWig fader or knob
10 turn a knob on the BSP and it works

so it seems to me that something is blocking the cc's getting through to the vst
but allowing them through to BitWig controls

If I use TOMS multi script  everything works perfectly ?

Another strange thing is.  With TOMS script I don't have to add a  generic midi clock transmitter

but with your script  Sometimes at random times  the BSP will NOT start when I press
play on BitWig     so I end up having to add a generic midi clock

the above happens at random times so I can't see what might be causing this

sorry to be a pain
I am Not a musician in any shape or form
I just love the sound of old analog synths
and spend many hours TRYING to sound like tangerine dream
without much success. But hey I have a lot of fun

cheers
Kev
 
BWS 3.0.0,Spark LE, V Collection 6.2, BS1 & BS PRO, Keystep & Keystep pro  keylab 25, Axiom pro 49,Behringer UMC1820,Launch pad pro,ProFx8 v2,Icon m+ & D2,KRK 10/3,win 10 pro,i7 5820k 4ghz ,16G ddr 4 ,1TB NVMe.M2, msi x99a sli + , NV GF Gt 710, Matrix Brute  Roland TR8S

bufobufo

  • Apprentice
  • Apprentice
  • *
  • Posts: 7
  • Karma: 4
Re: BeatStep Pro Not Sending CC Messages in Control Mode
« Reply #14 on: August 21, 2015, 05:15:29 pm »
Hi Kev,

thanks for the input. I just solved the CC/MIDI-learn problem, hope it works fine for you now..
The latest version is here:
https://github.com/justlep/bitwig

As for the Play/Stop issue, I haven't encountered it yet (at least not that I remember at the moment), but I'll keep an eye on it and see if it's a problem of the script.

Cheers ~
Lennart

 

Carbonate design by Bloc
SMF 2.0.17 | SMF © 2019, Simple Machines