December 04, 2023, 03:39:07 am
Welcome, Guest. Please login or register

Arturia Forums

Author Topic: microfreak + daw (reaper) + midi sync -> arp stops working  (Read 452 times)


  • Newbie
  • *
  • Posts: 2
  • Karma: 0
microfreak + daw (reaper) + midi sync -> arp stops working
« on: April 23, 2023, 08:48:48 pm »
hi everyone, new user here.

i recently bought a microfreak, and although i love it dearly, one issue is driving me crazy: i can't get the arpeggiator to function once i enabled midi sync.

-source: midi or auto
-global tempo: on
-clock: 48ppq
-input chan: all
-output chan:1
-output: midi
-local: on
-arp/midi seq out: on
-thru: off
-knob send cc: on
-merge: both

mf is connected through minikjack adapters to a midiface 4x4 interface, which in turn goes to the mac via usb.

reaper sends clock to the mf.
i have no active track in my project that sends to the mf – i just want the clock in order to sync a new arpeggio to previous recorded material.

i'm running reaper 6.7.8 on mac os 13.3.1.

please help  :'(

edit/clarification: the sequencer does work, once the play button is pressed manually – it's just the arpeggiator that refuses to work.
« Last Edit: April 23, 2023, 09:11:20 pm by cxh »


  • Apprentice
  • *
  • Posts: 7
  • Karma: 0
Re: microfreak + daw (reaper) + midi sync -> arp stops working
« Reply #1 on: May 18, 2023, 08:30:39 pm »
I have a very similar issue. Were you ever able to resolve this? I see no replies... and this is a major issue.

I bought the microfreak 6 days ago, and LOVE most of what it does, but I cannot get ARP working properly (consistently) inside my DAW, Cubase 12 pro.

C12 sync settings are correct as far as I know: microfreak is selected as sync target, always send START messages, TIMECODE sent in stop mode, MIDI clock follows project position, MIDI timecode follows project time

The first mF preset - Nervous Keys. If I try to arp this preset inside Cubase12, only one note plays. If I continuously tap on mF keys, the arp plays but instantly stops when I stop.
If I quit the DAW and play the mF by itself, Nervous Keys arpeggiates just fine.

If I cycle through many presets on the mF, which I have been doing every day since I bought it, I notice some presets will run patterns ok, but none will arpeggiate. I just tested another 20-30 presets while making this post, and yes - no arp preset works inside my DAW.

This is actually a fairly large issue. Does anyone have any additional info on this? If this cant be resolved, Ill be sending this back to my vendor ASAP.
« Last Edit: May 18, 2023, 08:37:17 pm by Milkman76 »


  • Apprentice
  • *
  • Posts: 7
  • Karma: 0
Re: microfreak + daw (reaper) + midi sync -> arp stops working
« Reply #2 on: May 19, 2023, 11:44:00 pm »
This is all very confusing and frustrating.

Arturia responded to my ticket about this.

They had me configure MMC Machine Control Output inside Cubase 12's MIDI sync panel. I was asked to set the Microfreak as the MMC Active Master, input not connected, output connected to the Microfreak
This, alone, did not work and my arp would still not play inside my DAW.

So I did my own tests. I tried changing the internal MIDI in/out settings on the Microfreak, and the arp started working inside my DAW!!!

Result: if I set the freak to ANY MIDI channel in/out, and I configure my DAW for a MIDI track set for that same MIDI Channel (default 1 in this case), the arp does not work in STOP or PLAY mode.
If I set my DAW..... to any OTHER MIDI CHANNEL than what the freak is set for, in this case I set my track to MIDI 2, the arp works in STOP and PLAY mode!!! MIDI records normally in/out.

If I set my DAW and my Microfreak........  to the SAME MIDI CHANNELS, like every other device in my studio, it wont work. I have to configure the MMC master above, as Arturia said I should, AND THEN I also have to make sure the Freak.... IS NOT on the same MIDI channel as the DAW.

This is super confusing, but so far isnt causing any problems with my other instruments. I asked Arturia's customer service if they can help me understand this, and also if the new 5.0 firmware will resolve or change this behavior. Right now my freak and my DAW work as intended.


Carbonate design by Bloc
SMF 2.0.17 | SMF © 2019, Simple Machines