May 23, 2024, 08:49:16 am
Welcome, Guest. Please login or register
News:

Arturia Forums



Author Topic: Analog Lab V plugin crashes GB: M1 + Monterey 12.6 21G115 + Garageband 10.4.7  (Read 3361 times)

ccshannon

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Steps to reproduce:

On M1 Mac running Monterey, with latest 5.6.0.2890, in Garageband, add a software instrument track, select plugins > Analog Lab V. Choose a preset set (ie "East Synth"). You don't even have to record anything on the track, just save the GB project and close it.

Now re-open it. First, you may be asked to "lower your security settings" on your Mac to be able to use Analog Lab in Monterey on M1 Mac. That doesn't sound good, and shouldn't be necessary, but say "OK" anyway.

The GB project can no longer be opened. It crashes while opening it. Sometimes GB doesn't crash but it does not display a screen. "Switching to" the GB app reveals the Open Project dialog.

Conclusion: Arturia Analog Lab is not ready for Garabgeband on M1 Macs running Monterey. Because of that, I am no longer using Analog Lab for anything. When I bought the new Mac, I transferred all my projects over from the old Intel one and found I could not open many of them - had I wiped my old system I would not be able to use these projects at all. I am now going through all projects on my old Mac that used Analog Lab and removing it completely, so I can bring those projects back over to the M1 Mac and open them.

EDITED TO ADD: To reproduce this, make sure you have most recent (as of 11/20/2022) MacOS Monterey 12.6.
« Last Edit: November 20, 2022, 09:38:30 pm by ccshannon »

ccshannon

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Okay, so I found a workaround. First, I had tried quitting GB and giving all 3 Arturia items (Analog Lab, com.Arturia.InstallHelper and Arturia Software Center) Full Disk Access under Sys Prefs > Security/Privacy. After making these changes, I still could not open a GB project that uses Analog Lab V. I always get the "Report, Reopen, Ignore" dialog.

But I was able to create a new GB project with an Analog Lab V plugin track, save it and reopen it. Maybe it's the use of presets? I'm not sure.

So, I decided to try "Reopen". Same issue, progress bar gets so far opening the project, then back to same dialog. So, I hit Reopen again ... and the project opened!

I tried this on another Analog Lab V GarageBand project.
  • Make sure GB is closed
  • From Finder, open GB project
  • When you get Report, Reopen, Ignore dialog, choose Reopen
  • If you the get dialog again, click Reopen
  • It should open and show unsaved changes (block dot on red circle in Finder window)


I have to do this every time I open a project using Analog Lab V, which is annoying, but at least I can access the project.

Bob Dole

  • Guest
I have the very same issue on my M1 with Ventura and GarageBand.  As soon as I open up the Analog Lab V plug, the GB project is hosed.  This is so disappointing.  Such a basic function and it doesn't work.  The GB/Lab V toolchain is now worthless.

sumo999

  • Apprentice
  • *
  • Posts: 12
  • Karma: 0
If you select Analog Lab after logging into Arturia Software Center, there is menu at bottom right that says clean preferences.  This is what worked for me the GarageBand/Analog Lab crash. At least for now.   (M1 iMac/Ventura)

 

Carbonate design by Bloc
SMF 2.0.17 | SMF © 2019, Simple Machines