April 18, 2024, 07:40:16 pm
Welcome, Guest. Please login or register
News:

Arturia Forums



Author Topic: Copy pattern error?  (Read 1061 times)

Proxi

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Copy pattern error?
« on: January 10, 2022, 02:58:58 pm »
New to the forum and tried searching this but not finding anything current, apologies if I'm missing something. Keystep Pro with latest firmware.

I try to copy a pattern from one slot to another on the same track. It works... occasionally. I've tried many variations, but I consistently get inconsistent results. Copying from pattern 2 to 6,7,8 with the copy button held down yields a successful copy only on 8. The others contain a partial copy -- about 1/4 of the notes of the original, but 8 is fine. I erase 6,7,8, and copy them individually, i.e. copy 2, paste 6. Copy 2, paste 7... None of them copy successfully. Mono/Poly, key, etc. are all the same and appear to be correct, but most copies don't copy all the notes. I'd think I was doing something wrong except that the same operations do and don't work at different times.

At this point the only thing I can do is copy all the steps individually then paste them, which for a four bar pattern means I'm pressing 64 buttons when I should be able to press one. Anyone have light to shed on this? Thanks...


Septcercles

  • Apprentice
  • *
  • Posts: 3
  • Karma: 0
Re: Copy pattern error?
« Reply #1 on: August 07, 2022, 12:40:05 pm »
I got the same copy/paste issues, and i can't believe it's not more shared by other user.
When i copy/past pattern, plenty of times ether the pasted pattern will have missing notes, ether the adjacent patterns will be corrupted.
I'm on the last firmware, i tried different usb cable to load it, full factory reset and even debug mode.
I use the KSP with my modular, only the CV/gate output used, no midi, no usb.
I opened a ticket, and Arturia replied that they are aware of this "bug", that might be corrected in a hypothetical new firmware.

this is such a thing that make the KSP unusable that i don't get that other user does not complain about it, that means to me that not all user have this problem, hence that it is not a bug in the firmware (That would mean everybody would experience this bug).  So far i tested two KSP and they both have this problem.
Very strange...

Other user, what are your experience on this ?

julienGB

  • Guest
Re: Copy pattern error?
« Reply #2 on: April 26, 2023, 06:28:26 am »
I have exactly the same problem here. Does anyone know something about this bug at Arturia ? I'm just trying to set variations of a specific long pattern for a live show ... and it's a big PITA ! The copy/paste fonction is totally unusable. It's wrecking all my workflow so i'm pretty disappointed by the Keystep Pro. :(

 

Carbonate design by Bloc
SMF 2.0.17 | SMF © 2019, Simple Machines