September 25, 2023, 06:05:44 am
Welcome, Guest. Please login or register

Arturia Forums

Author Topic: New MicroFreak not working?  (Read 1957 times)


  • Newbie
  • *
  • Posts: 2
  • Karma: 0
New MicroFreak not working?
« on: April 24, 2021, 06:00:08 pm »
Hi all,

Feeling very frustrated right now.

I just bought a MicroFreak (new), I unbox it and as I turn it on, sounds seem fine but none of the lights are working. The screen turns on but is stuck to 'MicroFreak' initial image, no way of navigating through the plugins or getting any other info.

So I finally connect it to my laptop, install MIDI Control Centre and proceed to update the firmware. Utility light now starts blinking but the update fails and the device is now bricked, stuck with utility light on and nothing else working, laptop doesn't even recognise the device anymore.

Things I tried:

- uninstalling Midi Control Centre and drivers and following the troubleshooting on the site but nothing.
- upgrading both on Windows 10 (on two different machines) and mac - result is the same, upgrade stuck at 20%

Is there a way of factory resetting the device? (the only I one I could find needs the screen so it's a no for me)

Please help - this is looking more and more like an expensive piece of junk.
« Last Edit: April 25, 2021, 11:00:57 am by StephenDedalus »


  • Apprentice
  • *
  • Posts: 3
  • Karma: 0
Re: New MicroFreak not working?
« Reply #1 on: April 25, 2021, 11:59:37 am »
try contacting Arturia I found them a great help


  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Re: New MicroFreak not working?
« Reply #2 on: May 20, 2022, 11:20:41 pm »
May I know what worked for you?


Carbonate design by Bloc
SMF 2.0.17 | SMF © 2019, Simple Machines