May 19, 2024, 10:12:45 pm
Welcome, Guest. Please login or register

Arturia Forums

Author Topic: Nothing works . . .  (Read 3156 times)


  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Nothing works . . .
« on: March 05, 2021, 09:13:06 am »
I've had my Keystep 37 for just a few days and it's been working fine until today. Nothing has changed in my setup. KS37 is set to USB (as it was last time I used it). It's connected to my iMac through a powered USB  hub which hasn't caused any problems.I've re-installed the latest firmware several times. I've powered down the KS37 and powered it back up with the switch and with both ends of the MIDI cable. I've let it sit for several minutes. I deleted the MIDI Control Center and re-installed it. I've tried re-starting the KS37 while holding down the octave keys. The LED does indicate 'rst' but the flashing light pattern is the same as a normal start. All sequences are gone. I tried storing one from the MIDI Control Center. The MCC declared it done after the process bar finished loading but it doesn't play. The Play / Pause button just flashes at about 60 beats per minute. It flashes continuously in both Sequence and Arp modes. The only functions that work are standard MIDI performance from playing the keys and the Chord encoder button. The LED indicates the number of steps I'm recording to a sequence but nothing will playback. The Tap button doesn't light up when used in recording a sequence and, according to the LED, it doesn't use a step in the sequence. I tried a reset start with the KS37 plugged into a separate wall socket USB (not connected to my iMac) but with the same fail. Help!


  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1.176
  • Karma: 67
Re: Nothing works . . .
« Reply #1 on: March 05, 2021, 12:21:34 pm »

Bear in mind this is a users' forum so likely you won't get a reply directly from Arturia. If you specifically want a reply from Arturia you would be best to raise a ticket via your account. Alternatively, there may be other users here who can offer constructive advice but you may have to wait until they see the thread.
2022 Apple Studio Max 32/32/2TB Monterey V Collection 9 Analog Lab 4 + 5 KeyLab 88 KeyStep


  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Re: Nothing works . . .
« Reply #2 on: March 13, 2021, 12:38:25 am »
similar problem here...  first day i got it i was able to see it in Midi Control Center and update the firmware.  messed around with Arturia Analog V and was able to make some sequences and stuff.  and then today i can't do anything with it.  Midi Control Center doesn't see it.  Ableton doesn't see it.  have a Mac running Catalina 10.15.4 and deleted it from Audio Midi Setup.  hooked it up again and it still doesn't show up in Midi Control Center.  ugh

really liked this thing when it was working and don't want to go back to my Launchkey 25, but at least that works every time....

Edit:  whoa!  had to reboot my Mac as part of something else i was doing and after that my Keystep now shows up in Midi Control Center again.  Was able to redo the firmware Update and now it's working fine.  guess i forgot step number 1 when dealing with computer issues --- REBOOT!!!!  :)
« Last Edit: March 13, 2021, 01:39:06 am by nombei43 »


Carbonate design by Bloc
SMF 2.0.17 | SMF © 2019, Simple Machines