May 26, 2024, 05:13:30 am
Welcome, Guest. Please login or register
News:

Arturia Forums



Author Topic: MIDI over USB works until I "play" (Ableton Live 10)  (Read 1641 times)

Digital Larry

  • Apprentice
  • Apprentice
  • *
  • Posts: 9
  • Karma: 0
MIDI over USB works until I "play" (Ableton Live 10)
« on: January 26, 2020, 08:53:40 am »
My BSP is plugged in via USB and detected in Ableton Pro 10.  If I map it to a MIDI track I can play the notes from the BSP pads. 

Then I press "play" on the BSP.  It looks like it is playing (lights are flashing) but nothing is getting received on MIDI.  Stop playback, and now playing with the PADs does not work.

I go into Ableton's MIDI settings and toggle the "TRACK" button for Beatstep Pro port 2.  Then it works again.

Ableton's MIDI settings include "TRACK", "SYNC", and "REMOTE" for each port, in and out.

I've set Sync on both BSP output ports, and "TRACK" and "SYNC" for the input ports.  Sync is set to "USB" on the BSP.

I'm not sure I'm describing it exactly but for some reason, it will stop sending MIDI to Live and then I toggle the "TRACK" button on port 2 as described before and it comes back.

Any idea what's going on?  It took my about an hour to get to this point.  My Keystation 32 and Ableton Push both work fine with Live.

BSP firmware is 2.0.1.  Windows 10.


Digital Larry

  • Apprentice
  • Apprentice
  • *
  • Posts: 9
  • Karma: 0
Re: MIDI over USB works until I "play" (Ableton Live 10)
« Reply #1 on: January 27, 2020, 06:26:21 am »
OK not sure what the deal is but I managed to get it working.  Maybe it's a Live issue but out of curiosity does anyone know why the BSP shows up with 2 MIDI ports when connected via USB?  I have a Softstep MIDI footswitch and it also reports 2 ports using MIDI via USB.  In that case it's expected although I don't recall why.

IllusionsUK

  • Apprentice
  • *
  • Posts: 4
  • Karma: 0
Re: MIDI over USB works until I "play" (Ableton Live 10)
« Reply #2 on: February 06, 2020, 08:18:57 pm »
I believe the 2nd port is for the MCU/HUI output in control mode.

In this setup video it shows you how to set up the Mackie Controls using the 2nd port. Worked for me.  :)

https://www.youtube.com/watch?v=d1kMa2piwyk

Beltramides

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Re: MIDI over USB works until I "play" (Ableton Live 10)
« Reply #3 on: April 22, 2020, 06:58:15 pm »
How did you managged to solve the problem?, i have same issue and its driving me mad...hope that u could th how to solve it thank u

Digital Larry

  • Apprentice
  • Apprentice
  • *
  • Posts: 9
  • Karma: 0
Re: MIDI over USB works until I "play" (Ableton Live 10)
« Reply #4 on: April 01, 2022, 02:15:42 am »
I started this topic so sorry to resurrect it but I only recently figured it out.

It looks as though the secret is to DISABLE SYNC IN in Live's preferences.  This doesn't seem to make any sense, because if it's NOT in "EXT" mode, why would having a SYNC INPUT enabled make any difference?

What I would see is that pads, whether you hit them or played a sequence, would send "something" to Live as shown by Live's MIDI Input indicator.  However, none of that would ever show up in a channel, even with "ALL INS" "ALL CHANNELS" enabled.  I tried putting the Live's Max MIDI monitor in a channel but it didn't show anything.

It's been about a week so far and since I did this, I haven't had a problem.

 

Carbonate design by Bloc
SMF 2.0.17 | SMF © 2019, Simple Machines