July 22, 2024, 06:16:16 am
Welcome, Guest. Please login or register

Arturia Forums

Author Topic: HELP! Tried updater, now device is locked up!  (Read 1016 times)


  • Apprentice
  • Apprentice
  • *
  • Posts: 49
  • Karma: 2
  • Noise noise noise.
HELP! Tried updater, now device is locked up!
« on: November 26, 2019, 03:03:38 am »
I tried installing the latest firmware update, everything went fine, until it said to reboot the device.  I turned it off and on, and the only thing I get is the opening screen that says "MICRO FREAK Algorithmic Synthesizer."  It is not making any sounds, basically nothing is happening.  Is it DEAD already???  I just bought this last month.  I've used it like THREE times.  I looked up "resets" online but there is NOTHING for a frozen screen.  All the rests involve the Utility knob working, and right now: NOTHING is working.

WHAT CAN I DO???  PLZ, someone.... HELP!!!

« Last Edit: November 26, 2019, 03:19:54 am by damnedcat777 »
"Why do single coil pickups hum? Because they don't know the words"


Carbonate design by Bloc
SMF 2.0.17 | SMF © 2019, Simple Machines