June 08, 2023, 02:52:56 am
Welcome, Guest. Please login or register.
Did you miss your activation email

Arturia Forums

Author Topic: Analog Lab 3_3_2_0_1509 incompatible with Ableton Live Intro 10.0.3  (Read 1422 times)


  • Sr. Member
  • ****
  • Posts: 254
  • Karma: 2
After installing Ableton Live intro 10, I tried to use the Analog Lab 3 version 3_3_2_0_1509 plug in and got an error message.
After trying to locate an answer and found none, I decided to go back to the previous version of Analog Lab 3 which is: 3_3_1_0_1391  and it works flawlessly.
I decided that it was possible that re-installing the last version might solve the problem since I had AL3 2_0_1509 before installing Ableton and so, I did reinstall the last version and NO!!!
I re-installed 1_0_1391 and it works again.

Another issue with Ableton Live Intro 10 is the Modular V version 3_3_3_0_1391 where the interface is so large that it is un-usable AND no plugs are available etc.  Obviously, someone changed something in versions 3_3_2 of AL3 and 3_3_3 of Modular V which screwed things up.

It would be nice to have REAL PROGRAMMERS know what they are doing before releasing modified versions of a software.  I should know since I've written software since 1976 and have rarely put out problem software.  On the other hand, I never allowed myself to be pressured when programming, since that will generate more bugs than an insectorium.

I doubt this problem will be fixed since I've complained about a bug in Modular V for two years now and no fixes were done, even in the last update.  I guess you can't expect perfection in today's world.
« Last Edit: September 30, 2018, 03:30:03 am by gphantom »


  • Sr. Member
  • ****
  • Posts: 254
  • Karma: 2
Re: Analog Lab 3_3_2_0_1509 incompatible with Ableton Live Intro 10.0.3
« Reply #1 on: October 01, 2018, 05:24:18 pm »
So far, it does appear that Windows 10 is the culprit.  I have all updates so there's no issue there.  I have two screens and noticed that when I try Modular V 3 with Ableton Live 10 Intro, the Modular V 3 background image takes up both screens in size.  Disabling one screen and the background image takes up only 1 screen.  Tried reducing the resolution of my display - Nothing.  Tried using version of Modular V and the background image is displayed with some patch cords but the plugs are off-center as well as the dials and no sound available.  I got AL3 latest version to finally work ( but, B#1, B1, C2, C#2 and C5 don't work (I have the Keylab Essential 49 but when going one octave up, C5 and above don't work - CRAZY)

Booted up windows 7 (Same machine, one SSD for XP, one for Windows 7 and one SSD for Windows 10 so bootup is fast enough for me to switch often if needed)
Tried AL3, versions and the previous version - No problems at all
Tried Modular V and - No problems at all.

TADA!!!!  Windows 10 has a problem with driver handling.  My display card is a Sapphire AMD HD6670 with 1Gig memory and in Windows 10, I tried downloading a previous driver as well as the one that Microsoft makes available as a default.  Nothing.  Therefore, the core Windows 10 driver handling causes a problem between the sound card and/or USB port (for Keylab Essential) and/or the DIsplay card.  (Explains why only background images are displayed full screen and the software can't plug in the dials/patch cords etc.  An interrupt is probably hanging up and the software can't continue since it didn't receive a go ahead)

My next step will be to change my display card to see if anything changes.  As soon as I get some money.


Carbonate design by Bloc
SMF 2.0.17 | SMF © 2019, Simple Machines