July 18, 2024, 12:41:28 am
Welcome, Guest. Please login or register
News:

Arturia Forums



Author Topic: Problems Setting Up MIDI CC From Encoders  (Read 2918 times)

calvinsomething

  • Apprentice
  • Apprentice
  • *
  • Posts: 12
  • Karma: 0
Problems Setting Up MIDI CC From Encoders
« on: September 24, 2015, 04:41:57 pm »

So I'm having problems assigning the encoders to control parameters within an MFB-503. I'm assigning the CC# of each encoder to the numbers corresponding each function in this pdf http://mfberlin.de/wp-content/uploads/MFB-503_MIDI_deutsch.pdf.

I've never really used MIDI to this extent before so I might be missing something obvious... I successfully mapped the pads to each drum, although when I play what is supposed to be a regular sound, the velocity I press it affects accented sounds of the same drum. Like if I have an accented kick in the sequence, and I press the pad for the regular kick at a lower velocity, the accented kick adjusts to the same velocity... really strange.

Anyway, the main issue is the encoders because I would love to tune the drums from the beatstep.

Thanks if anyone can help...

Terrym

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1.542
  • Karma: 40
    • soundcloud.com/logicaldream
Re: Problems Setting Up MIDI CC From Encoders
« Reply #1 on: September 24, 2015, 07:16:19 pm »
Hi when in the mmc control page are you using usb or midi . as there is a setting there for both just in case you are using usb . the default is not set to midi.
also is the midi channel set correctly for control.


regards


terrym
TerryM
ARTURIA Tester for Minifreak,All software Polybrute,Keystep pro,Audiofuse range, Microfreak,Kl49mkII,DrumBrute,Spark,Analog lab3,KLE,kl88,matrix12,Semv,Beatstep,Minibrute 2,Pigments
ASC,Vcol6, Beatstep pro, VCOL8, Synclavier v.Minibrute2s

calvinsomething

  • Apprentice
  • Apprentice
  • *
  • Posts: 12
  • Karma: 0
Re: Problems Setting Up MIDI CC From Encoders
« Reply #2 on: September 25, 2015, 05:17:14 pm »
I'm not sure what you're saying. When I'm in the MIDI control program I'm looking at ControllerMap and I bring each of the encoders up, set the CC # as I said in my original post, and the encoders are all set to CC and MIDI by default. And yes the MIDI channel is correct or I wouldn't be able to play the pads.

Terrym

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1.542
  • Karma: 40
    • soundcloud.com/logicaldream
Re: Problems Setting Up MIDI CC From Encoders
« Reply #3 on: September 25, 2015, 06:21:36 pm »
Do you have midi ports set to usb/midi (screenshot) and are you saving to a template then sending to the bsp.




Terrym
TerryM
ARTURIA Tester for Minifreak,All software Polybrute,Keystep pro,Audiofuse range, Microfreak,Kl49mkII,DrumBrute,Spark,Analog lab3,KLE,kl88,matrix12,Semv,Beatstep,Minibrute 2,Pigments
ASC,Vcol6, Beatstep pro, VCOL8, Synclavier v.Minibrute2s

calvinsomething

  • Apprentice
  • Apprentice
  • *
  • Posts: 12
  • Karma: 0
Re: Problems Setting Up MIDI CC From Encoders
« Reply #4 on: September 25, 2015, 11:11:17 pm »
No I had it set to just MIDI because that's what I'm using. I will try MIDI/USB and see if that changes anything.

calvinsomething

  • Apprentice
  • Apprentice
  • *
  • Posts: 12
  • Karma: 0
Re: Problems Setting Up MIDI CC From Encoders
« Reply #5 on: September 25, 2015, 11:20:31 pm »
Thanks! It worked. Only thing is... whenever I change a value with the encoder, I can hear it when I play the corresponding drum pad from Control Mode, but when I switch to Drum mode the sound reverts to the original value :(

If I play the pattern first, then switch to Control Mode, the changes I make revert as soon as the sound is triggered again :(

I don't know if this is something that the Beatstep is doing or the MFB...

 

Carbonate design by Bloc
SMF 2.0.17 | SMF © 2019, Simple Machines