July 25, 2024, 01:43:57 am
Welcome, Guest. Please login or register
News:

Arturia Forums



Author Topic: DP 8 crashing at opening after installing VC4.  (Read 5913 times)

midilance

  • Apprentice
  • Apprentice
  • *
  • Posts: 8
  • Karma: 0
DP 8 crashing at opening after installing VC4.
« on: December 04, 2014, 05:22:20 pm »
DP has been running fine on Yosemite.  Now it won't open without crashing. My crash report is included.
Mac Pro 2.66 GHz, 5 GB Ram, OS 10.4.10, Digital Performer 5.12, MotU 828 MK II, MTP AV USB, Kontakt 3, Reason 3, Minimoog V, Stylus RMX, NI B4 II, DrumCore 2, BFD 1.5, Autotune5, Korg Legacyl, Altiverb, UAD1e, Amplitube2.

tdunst

  • Apprentice
  • Apprentice
  • *
  • Posts: 4
  • Karma: 0
Re: DP 8 crashing at opening after installing VC4.
« Reply #1 on: December 06, 2014, 09:47:03 pm »
DP8.07 (latest version) Is crashing for me me as well.  If you remove all the .component files from you library folder, DP8 will launch, but then NONE of the Arturia instruments will play, not even my old V3 versions.  This is REALLY unacceptable.  Come on Arturia, do you really expect us to believe that you didn't test this???  When can we expect a fix for this???

Terrym

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1.542
  • Karma: 40
    • soundcloud.com/logicaldream
Re: DP 8 crashing at opening after installing VC4.
« Reply #2 on: December 06, 2014, 10:00:19 pm »
Hi . i don't use dp but i looked at your report and noticed you use all plugin platforms on scan .have you tried just using the plugins in one format . also do your arturia plugins work in standalone.
as i said i don't use dp but maybe try organizing your plugins so you don't have doubles .


terrym


TerryM
ARTURIA Tester for Minifreak,All software Polybrute,Keystep pro,Audiofuse range, Microfreak,Kl49mkII,DrumBrute,Spark,Analog lab3,KLE,kl88,matrix12,Semv,Beatstep,Minibrute 2,Pigments
ASC,Vcol6, Beatstep pro, VCOL8, Synclavier v.Minibrute2s

tdunst

  • Apprentice
  • Apprentice
  • *
  • Posts: 4
  • Karma: 0
Re: DP 8 crashing at opening after installing VC4.
« Reply #3 on: December 06, 2014, 11:38:30 pm »
The plugins work in stand alone mode.  I tried your suggestion, removing all of the VST and VST3 plugins, leaving only the AU (.component) plugins, and DP8 still crashes on startup.  I have dozens of other soft synth installed with all different formats including VST and I have never had any problems.  Thank you for your suggestion, but V Collection 4 is still completely incompatible with DP8.

midilance

  • Apprentice
  • Apprentice
  • *
  • Posts: 8
  • Karma: 0
Re: DP 8 crashing at opening after installing VC4.
« Reply #4 on: December 07, 2014, 01:19:02 am »
I had this problem.  I'm using OX10.10.1 and DP 8.07.  After installing VC4 I DP crashes on startup.  I contacted Arturia tech support.  They are aware of the problem.  There is a temporary workaround that worked for me.  Here is what they said:

"This is a bad one but our plugins might crash the AU validator of Digital Performer. To make them work user need to clear AU cache of DP then run DP and skip the AU scan as soon as scanning window appears. Then in DP preferences he can scan and validate our plugins one by one.

Clear AudioUnit cache of Digital performer :

You will need to hold down Alt and select Go -> Library to view the User Library.
In Library/preferences delete these folders:
com.motu.Digital Performer (folder)
com.motu.MotuAudioSystem (folder)
Note: only 1 of these files might exist, delete all that you find."  Then, run DP and skip the AU scan as soon as scanning window appears. Then in DP preferences you can scan and validate our plugins one by one.
Mac Pro 2.66 GHz, 5 GB Ram, OS 10.4.10, Digital Performer 5.12, MotU 828 MK II, MTP AV USB, Kontakt 3, Reason 3, Minimoog V, Stylus RMX, NI B4 II, DrumCore 2, BFD 1.5, Autotune5, Korg Legacyl, Altiverb, UAD1e, Amplitube2.

tdunst

  • Apprentice
  • Apprentice
  • *
  • Posts: 4
  • Karma: 0
Re: DP 8 crashing at opening after installing VC4.
« Reply #5 on: December 07, 2014, 04:39:18 am »
Thank you midi lance!!  I have WAY to many custom preferences setup to completely blow away my DP8 preference folder, so this didn't work for me.  HOWEVER.... I experimented with adding the plugins in on-by-one to see which ones were really causing the problem.  Surprisingly, all of the new instruments seem to work fine, but 2 of the classic instruments consistently crash DP8 every single time:

1. MINI V
2. Prophet V

So this is what worked for me:

Remove ALL of the Arturia V Collection 4 components from the /Library/Audio/Plug-Ins/Components
Then add them back one-by-one starting DP 8 between each plugin addition (this allows DP to add them to the AU cache one at a time)
DO NOT add the following plugins:
1. Mini V2 Efx.component
2. Mini V2.component
3. Prophet V2.component

This should allow you to run all of the Arturia V Collection 4 plugins EXCEPT the Prophet and Mini.  One other drawback to this workaround is that during AU validation (even for the plugins that are 'working'), several of the Arturia instruments issue a warning indicating that degraded performance (latency) will likely occur.  I'm not sure what this means exactly, and I have not as-of-yet had a chance to play all of the plugins, so I can't report on their performance.  I can tell you however that the new Matrix V plugin consumes an INCREDIBLE amount of CPU.  I have a very powerful Macbook Pro with a 4Qi7 and 16GB of RAM and a single instance of Matrix V consumes 25% of my CPU to play a single note!!  It does sound amazing however, so I am hoping that Arturia can provide some patches that address the performance.

In general, I would consider this a hack at best, and I am very disappointed with Arturia for the sloppiness in this release.  I really need my Prophet and MINI back as these are the two plugins that I rely on the most.  PLEASE provide a fix for the V Collection 4 ASAP!!!

achim@zwischengeschoss.de

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Re: DP 8 crashing at opening after installing VC4.
« Reply #6 on: January 07, 2015, 03:30:02 am »
I'm running 10.9.5 and ASC 1.0.3.412 crashes repeatedly right after startup with the following crash-report. Cannot activate my products.

Does anyone know what "mutex lock failed: Invalid argument abort() called" might be?

Tried to repair permissions already. No success.


Process:         Arturia Software Center [2006]
Path:            /Applications/Arturia/Arturia Software Center.app/Contents/MacOS/Arturia Software Center
Identifier:      com.Arturia.ArturiaSoftwareCenter
Version:         1.0.3 (1.0.3.412)
Code Type:       X86-64 (Native)
Parent Process:  launchd [271]
Responsible:     Arturia Software Center [2006]
User ID:         502

Date/Time:       2015-01-07 09:41:59.723 +0700
OS Version:      Mac OS X 10.9.5 (13F34)
Report Version:  11
Anonymous UUID:  A00D50F1-ECE4-FE05-8D2F-C108A1E07390


Crashed Thread:  0  Juce Message Thread  Dispatch queue: com.apple.main-thread

Exception Type:  EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000

Application Specific Information:
terminating with uncaught exception of type std::__1::system_error: mutex lock failed: Invalid argument
abort() called

 

Carbonate design by Bloc
SMF 2.0.17 | SMF © 2019, Simple Machines