April 19, 2024, 06:44:25 am
Welcome, Guest. Please login or register
News:

Arturia Forums



Author Topic: PBConnect and Logic Pro  (Read 629 times)

Flemming Nordkrog

  • Guest
PBConnect and Logic Pro
« on: February 13, 2023, 03:28:36 pm »
Hi
I just got the Polybrute and are having a nightmare getting it to work with Logic Pro.
PBConnect is installed, I can insert it on a virtual instrument track and the plug in communicates as expected with the synth.
I hit record and record some midi notes from the synth, all seems fine, except that synth is sending out Data LSB, Data MSB, non reg LSB and non reg MSB constantly.
And - THIS MY MAIN ISSUE - when I try to record knob movements from the synth, eg. a filter cut off, no proper CC data is recorded, only more LSB data. And when I play back the the midi, the filter is clearly not receiving any filter movements back from Logic.
I have tried to mess with settings-cc on/off and also in Logic tried to ignore either MIDI og VST data from the PB. When ignoring VST I don't get the LSB/MSB data, but no cc data either (except from the mod wheel).
Any ideas? Anyone has experienced the same?
If there's no work around for this, I will have to send back the unit...  :-[
For info: I own a Korg Minilogue and I have no problems recording cc from that into Logic...
Thanks in advance for any help
Flemming

Flemming

  • Guest
Re: PBConnect and Logic Pro
« Reply #1 on: February 13, 2023, 04:14:46 pm »
A little update: I downloaded a demo of Ableton Live  just to test the PBConnect and in Live it works at it should (using AU)
Either there's a setting in Logic that needs to be changed or the PBC AU is does not work in Logic.
If anyone has an idea about what's going on, please let me know!
Flemming

 

Carbonate design by Bloc
SMF 2.0.17 | SMF © 2019, Simple Machines