June 13, 2024, 07:59:13 am
Welcome, Guest. Please login or register

Arturia Forums

Author Topic: Minilab MkII mapping to MPC Beats: knobs produce strange results  (Read 2782 times)


  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Minilab MkII mapping to MPC Beats: knobs produce strange results
« on: September 07, 2021, 04:07:04 am »
Hi folks,

Iíve having a heck of a time getting the knobs on the Minilab MkII to control the Q-Links in Akaiís MPC Beats in a usable way. I've seen that there's a long history of "jumpy knobs" reports over the past few years, and I can't say whether this issue is the same as what others are talking about, but I've gathered some specific data on this behavior and I'm hoping someone can help me resolve it.

Iím a bit new to this setup, but I've gotten some of the most common knob issues out of the way:
  • I understand the difference between absolute and relative, and my knobs are mapped as relative.
  • Iím aware of the knob speed issues, and I did update to firmware 1.1.2 to improve knob speed.
To provide some solid data on the behavior Iím seeing, I ran a test using knob 5 on the Minilab to control Sequence Tempo in Akai MPC Beats.

Minilab Knob 5 (CC 77) mapped to MPC Q-link 13 (Sequence Tempo)
Set as Relative CC offset, Channel 1, not flipped

Opening the project, the sequence tempo was preset to 120 bpm. I began by rotating the knob clockwise until the tempo value ceased to change, and then rotated it counterclockwise until the tempo value again ceased to change. I repeated this pattern 4 times. The changes to the tempo value are shown in the following table.

RotationStart valueGoes toThen to

In every case, the pattern was the same. The tempo value initially changed in the direction opposite what the knob rotation should have produced, then it reached a point where it reversed direction and began to change in the direction that matched the knob rotation. Eventually the value stopped changing, but nowhere near the limits of the controlís range. The peaks at both the high and the low ends get slightly lower over each iteration.

The other knobs show similar behavior. I chose tempo for the test since it provides such a nice linear curve with a large value spread, but I definitely have seen the values in other knobs move in the opposite direction of the knobís rotation.

I also tried setting the knob speed to Off, Medium, and Fast in the MCC, but I saw no noticeable change in behavior with those changes. I expected that when I set it to Off, the old slow rotation would return, but it did not.

Iím a bit stumped. Any ideas on how I might correct this? Has anyone else experienced similar behavior?

Thanks much for any insights!

Alex H.

Some system info
Arturia Minilab MkII, firmware version 1.1.2.
Akai MPC Beats version 2.10.0
Windows 10 Pro
« Last Edit: September 09, 2021, 12:47:36 am by jah1138 »


  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Re: Minilab MkII mapping to MPC Beats: knobs produce strange results
« Reply #1 on: September 13, 2021, 01:32:16 am »
Well, I fixed my encoder problem by giving up trying to fix my encoder problem.

I finally just started started over from scratch. I created a new template in the Midi Control Center and set up all the encoders again, and then created a new map in MPC Beats and mapped the encoders to the Q-Links all over again. Everything is working as expected now.

I still donít know what settings could produce the odd behavior I reported  the other day. I spent hours trying to adjust my controller settings and midi maps, with no effect. It  might just remain a puzzle!



  • Apprentice
  • *
  • Posts: 4
  • Karma: 0
Re: Minilab MkII mapping to MPC Beats: knobs produce strange results
« Reply #2 on: October 25, 2021, 04:33:33 pm »
I had problems getting my Minilab Mk II properly configured to work with MPC Beats.
Here is a webpage that documents exactly how I got it to work.



Carbonate design by Bloc
SMF 2.0.17 | SMF © 2019, Simple Machines