May 30, 2023, 02:00:38 am
Welcome, Guest. Please login or register.
Did you miss your activation email

Arturia Forums

Author Topic: Spark 2 Not Working  (Read 2924 times)

Oliver Cherer

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
Spark 2 Not Working
« on: November 17, 2020, 10:04:21 am »
Hi. Been ussing Spark 2 since it came bundled with V Collection 4 and it's now replaced all my other beatbox vsts but it's suddenly stoped working.  It doesn't load as a stand alone, not even getting to the GUI and if I open it as a plugin it crashes Cubase - i.e. it shuts Cubase down.  I'm Windows 10 with Cubase 11. Tried a few fixes suggested by Arturia Support but havent got anywhere.  Anyone recognise this problem?


  • Hero Member
  • *****
  • Posts: 4.891
  • Karma: 261
Re: Spark 2 Not Working
« Reply #1 on: November 17, 2020, 07:00:47 pm »
Hi and welcome to Arturia forums.

Spark load fine as standalone on Windows 10 here.
What have you tried to do?

Have you installed new stuff or updated anything, when it stopped working?
« Last Edit: November 17, 2020, 07:02:50 pm by LBH »


  • Apprentice
  • *
  • Posts: 11
  • Karma: 0
Re: Spark 2 Not Working in Stand Alone Mode
« Reply #2 on: October 09, 2021, 01:15:20 am »
Just in case this helps someone...

I was wondering why I couldn't find the Spark 2 (Stand Alone) icon.
I discovered that Windows 10 does not see Spark 2 (Stand Alone) as a 64bit program, so it installs it in the "Program (x86)" folder.
But once I found and clicked on it, it worked just fine.



  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Re: Spark 2 Not Working
« Reply #3 on: November 18, 2022, 06:32:18 pm »
I am trying to run it in Windows 11 but the standalone will not open as you experienced. I have found the exe that should open the standalone but even invoking the exe as administrator still does nothing. It crashes both Komplete Kontrol and Unify when I select it.

I have reinstalled it and uninstalled it. Reboot between installs and uninstalls as well as copied the spark.dll to different locations and even ran the latest Windows installer from the Arturia website and tried running it in Demo mode but it will not run.

What am I missing or is it simply no longer compatible with Windows (maybe a recent Windows update created this incompatibility)?


Carbonate design by Bloc
SMF 2.0.17 | SMF © 2019, Simple Machines