July 18, 2024, 01:07:27 am
Welcome, Guest. Please login or register
News:

Arturia Forums



Author Topic: BSP Record button triggering changes in Volca Drum  (Read 1046 times)

Sjo-erd

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
BSP Record button triggering changes in Volca Drum
« on: May 05, 2020, 10:26:44 pm »
Hey guys, I'm new to Arturia and have mostly been playing with Volcas up to this point.
I bought a BSP to expand my capabilities, but unfortunately I've run into a problem: The BSP triggers a change in my Volca drum when I press record, and I don't understand what is going wrong.

There's a link to a video showing the issue here: https://drive.google.com/open?id=1rvo_xK1fPgXXMpvwXcq5lL9TcWV82OMI

The Volca Drum is in split-channel mode with each pad being from 1-6.
It receives everything correctly from the clock to the sequences.

What I've tried so far:
- Hard Reset of BSP
- Reinstalling Midi Control center
- Updating firmware of both units

So far nothing works and the issue persists.

Does anyone have an idea on what might be wrong?

I have around two weeks before I have to send it back if it doesn't work but I'd love to find a solution for it and actually use it.

Thank you!

megamarkd

  • Hero Member
  • *****
  • Posts: 835
  • Karma: 38
  • Dead By Dawn
Re: BSP Record button triggering changes in Volca Drum
« Reply #1 on: May 18, 2020, 09:15:04 am »
Ahh this old chestnut.  The BSP is set up to send MIDI CC's when the transport buttons are used.  They are 50, 51 and 52, which are used by many, many synths that allow parameter tweaking via MIDI, including the Volca Drum.  You can deal with this in two ways, a) turn off RX short messages on the Volca (and stop it from being controlled by an external sequencer :( ) or b) change which CC's are sentby the BSP/disable sending CC's (the more desirable solution :D )

To change or disable the CC's, go into the device setting in MCC.  Under transport, there is the option to change what is sent with the regular transport messages.  You can change that to off and that will solve the issue.  If for some reason you don't want to switch it off, you can change the CC's sent to something which is not going to mess with any of the parameters on your instruments (popular choice for that is CC124 "Omni Mode off" as generally any instrument you are sequencing you want to only receive on one channel).
Currently running https://www.modulargrid.net/e/racks/view/1311723 / www.modulargrid.net, sequencing with KSP and recording with a Zoom (no DAW involved, for better or worse ;) )

Sjo-erd

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
Re: BSP Record button triggering changes in Volca Drum
« Reply #2 on: May 18, 2020, 09:29:31 am »
Hey megamarkd,

I figured it out this weekend, but hadn't updated this thread yet.
Took me a while to understand where the option was in Midi Control Center.

Thank you for the very clear explanation!

In the end I went with a midi signal that was not mapped to anything on the volca drum, and that works for now.

 

Carbonate design by Bloc
SMF 2.0.17 | SMF © 2019, Simple Machines