June 22, 2024, 01:40:00 pm
Welcome, Guest. Please login or register
News:

Arturia Forums



Author Topic: Huge latency issues with new Keystep in all DAWs  (Read 1055 times)

puzzl

  • Guest
Huge latency issues with new Keystep in all DAWs
« on: February 26, 2023, 05:35:23 pm »
This is my first foray into digital audio, so I don't know much what I'm doing. I've got a Keystep 37 plugged into a Windows 11 machine. I've installed Ableton Live Lite that came with it and was getting a huge amount of latency, 100+ms, so I looked that up and everyone says the same thing: lower the buffer. I've lowered the buffer as far as it will go without crackling and I'm still at 60ms. So I've tried installed other audio drivers: ASIO4ALL, FL ASIO, "Generic Low Latency ASIO" from Cubase. ASIO4ALL is actually giving me good latency of 4ms but it's basically a non-starter with it blocking all other audio streams, as I'm trying to play along to music on my computer... the other two "low latency" options are still giving me 60ms, and it doesn't seem to matter if I'm in Ableton, Cubase, or FL Studio.

What could be causing this? This can't be expected, can it? I'm on a powerful computer, and the CPU usage graph never goes above 10%. In the FL ASIO driver, I have the buffer set as low as it will go (256), I guess it's just not low enough? In the built-in driver I can get the buffer down to 800ish, which it says is giving me 30ms latency but it still feels awful to play. I'm becoming rapidly discouraged, I basically can't even use this thing right now.

puzzl

  • Guest
Re: Huge latency issues with new Keystep in all DAWs
« Reply #1 on: February 26, 2023, 05:41:35 pm »

 

Carbonate design by Bloc
SMF 2.0.17 | SMF © 2019, Simple Machines